BlogDocs

fix: Fix error messages stating "Please install it with [object Promise]"(#19259)

Merged
Merging
oohwooh:patch-1
into
main
-2%
IMPROVEMENTS
0
REGRESSIONS
0
UNTOUCHED
4
NEW
0
DROPPED
0
IGNORED
0

Benchmarks

client generation ~50 Models
packages/client/src/__tests__/benchmarks/huge-schema/huge-schema.bench.ts::typescript::client generation ~50 Models
-1%
1.8 s
1.8 s
typescript compilation ~50 Models
packages/client/src/__tests__/benchmarks/huge-schema/huge-schema.bench.ts::typescript::typescript compilation ~50 Models
-6%
20.3 ms
21.5 ms
client generation 100 models with relations
packages/client/src/__tests__/benchmarks/lots-of-relations/lots-of-relations.bench.ts::typescript::client generation 100 models with relations
0%
10.8 s
10.8 s
getPlatform
packages/get-platform/bench/get-platform.bench.ts::get-platform::getPlatform
-1%
13.9 ms
14 ms

Commits

Click on a commit to change the comparison range
base
main
550812e
-46%
Add missing awaits to `getPackageCmd` calls This fixes error messages stating "... Please install it with [object Promise] ..."
6a190df
a year ago by oohwooh
+45%
Merge branch 'main' into patch-1
28dc4cd
a year ago by Jolg42
ResourcesHomePricingDocsBlogGitHub
Copyright © 2024 CodSpeed Technology SAS. All rights reserved.