Commits
Click on a commit to change the comparison rangefix(linter): improve prefer_namespace_keyword rule
This commit enhances the `prefer_namespace_keyword` rule in the TypeScript linter:
- Introduce helper functions `is_nest_module`, `is_valid_module`, and `is_invalid_module` to improve code readability and maintainability
- Refactor the main `run` function to use these new helper functions
- Add support for detecting and fixing nested module declarations (e.g., `module A.B {}`)
- Update test cases to cover nested module scenarios
- Improve error reporting for nested modules test(linter): correct nested module handling in prefer_namespace_keyword rule chore(linter): Removed unnecessary context parameter from `is_valid_module` function. chore(linter): Refactor `prefer_namespace_keyword` rule in TypeScript linter
- Simplified `is_nest_module` function by removing redundant line breaks. fix(linter): remove redundant diagnostic return in `prefer_namespace_keyword` rule
- Removed an unnecessary return statement in the `prefer_namespace_keyword` rule to ensure proper execution flow and prevent premature diagnostic reporting. Merge branch 'main' into fix/4651